p650 and g450 on same machine

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

p650 and g450 on same machine

Postby piers » Mon Jun 22, 2009 2:12 pm

Hi forum,

I want to use p650(agp) and g450(pci) cards on the same machine to facilitate 3 or 4 monitors of the same type.

Can the mtx driver be used for both cards or do i have to have the mtx installed for the p650 and the mga installed for
the g450?

Are there any gotchas you might share with me before i tackle this?
I currently have the p650 working ok with the enlightenment r16 window manger - i would like to use this for the 3/4 monitor setup.

thanks
Piers
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London

Re: p650 and g450 on same machine

Postby xdreamer » Mon Jun 22, 2009 2:34 pm

Hi,

I had the same configuration using Xorg version 1.4. You have to use the mtx and the mga driver as provided on this page or directly from Matrox.

With the new version of Xorg (1.5+) the mga driver will unfortunately not work, as posted several times in this forum. If you are experienced you might get it running, by supporting the adaption of the proprietary driver.

At least for me I removed the g450 graphics adapter.

Best regards,
Robert
xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm

Re: p650 and g450 on same machine

Postby piers » Mon Jun 22, 2009 3:22 pm

Thanks Robert,

How do you install the mga driver given the mtx is already installed?

The matroxdriver_mga-x86_32-4.4.2-installer.run programme exits because "An X driver exits" already.

thanks
Piers
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London

Re: p650 and g450 on same machine

Postby piers » Mon Jun 22, 2009 4:52 pm

I just realised my centos version came with the mga driver already installed hence it warning of an overwrite - i was thinking it would overwrite the mtx driver. So please disregrad my last post. An lsmod shows both the mtx and mga now.

My problem now is this: on starting x, the two screens on the p650 are ok but the 3rd one on the g450 is a blank/on the e16 windows manager it comes up as a pixilated black and turquoise third of the deskspace. I have attached my xorg.conf and Xorg.log - if anyone could take a look, i would be very grateful.

thanks
Piers
Attachments
Xorg.0.log
(58.15 KiB) Downloaded 508 times
xorg.conf
(3.93 KiB) Downloaded 472 times
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London

Re: p650 and g450 on same machine

Postby xdreamer » Mon Jul 06, 2009 8:46 pm

Hi,

did you solve your problem in the mean time?

Your xorg.0.log doesn't show any MGA driver output.
Are you sure, your module is loaded properly?
Have you set the overwrite flag during mga matrox installer? Otherwise it might use the distributions one.
(WW) MTX: No matching Device section for instance (BusID PCI:6:0:0) found

This seems somewhat strange to me.

What might help, in my case it wasn't necessary, but it is described anywhere here, that you have to switch order of dectection in BIOS (AGP<->PCI)

Please try to enable the screen 0 argument in the device section.
Also this setting should be enabled:
#Screen "Display 3" RightOf "Display 2"

(I assume you commented it out before uploading the files :D )
xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm

Re: p650 and g450 on same machine

Postby piers » Mon Jul 06, 2009 9:13 pm

hi,
yes i did an overwrite for the mga but gave up on it...
i ended up buying a second p650 in pci form. now have the 3 1680x1050s going ok.
thanks anyway
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London


Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 3 guests

cron