Unable to use Framebuffer with G400

This forum is used for all questions regarding the use of Matrox graphics hardware with framebuffer drivers

Unable to use Framebuffer with G400

Postby daw3b » Mon Jan 29, 2007 8:32 pm

hi all,
after compiled kernel with howto specifications to use fb with g400
I still cannot use it...
In dev dir I just have fb0 and not fb1, if I try to start x with usefbdev I got following
errors
Code: Select all
(WW) open /dev/fb0: No such device
(WW) open /dev/fb1: No such file or directory
(WW) open /dev/fb2: No such file or directory
(WW) open /dev/fb3: No such file or directory
(WW) open /dev/fb4: No such file or directory
(WW) open /dev/fb5: No such file or directory
(WW) open /dev/fb6: No such file or directory
(WW) open /dev/fb7: No such file or directory
(EE) Unable to find a valid framebuffer device
(EE) MGA(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
   (you may have to look at the server log to see warnings)

I'm also a new linux user so I have no idea about what to do
daw3b
Private
Private
 
Posts: 5
Joined: Mon Jan 29, 2007 8:25 pm

Postby tuxx-home.at » Tue Jan 30, 2007 8:52 am

with howto specifications to use fb with g400


What HOWTO?

Could you please attach your kernel configuration to the next message?
If available, the file /proc/config.gz would be nice.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby daw3b » Tue Jan 30, 2007 10:44 am

tuxx-home.at wrote:What HOWTO?

I saw many howtos says to enable same modules like following
Code: Select all
Processor type and features > MTRR support
   (This speeds up image writing to your video card)

Character Devices > I2C support > I2C support
Character Devices > I2C support > I2C bit-banging interfaces
   (This will make sure you can select a few more options in Console
   drivers)

Character Devices > I2C support > I2C device interface

Character Devices > Matrox g200/g400
   (This will make the mga.o driver)

Console drivers > Frame-buffer support > Support for frame buffer devices
Console drivers > Frame-buffer support > Matrox acceleration
Console drivers > Frame-buffer support > G100/G200/G400/G450 support
Console drivers > Frame-buffer support > Matrox I2C support
Console drivers > Frame-buffer support > G400 second head support

Could you please attach your kernel configuration to the next message?
If available, the file /proc/config.gz would be nice.

I'll do this evening when I'll have my pc in my hands.pls tell me if other files
are useful as xorg.conf or entire xorg.0.log
daw3b
Private
Private
 
Posts: 5
Joined: Mon Jan 29, 2007 8:25 pm

Postby tuxx-home.at » Tue Jan 30, 2007 11:18 am

I saw many howtos says to enable same modules like following


Did you compile these options _INTO_ your kernel (by setting them to '*')
or did you compile them as modules (by setting them to 'M')?

Framebuffer devices, that are used during bootup should always be compiled
into the kernel instead of being configured as loadable kernel modules.

The list of modules basically looks good, but tell me how you did enable them.
Have you recompiled your kernel and installed the newly created kernel
image afterwards? Simply enabling these options is not enough, you know...

According to the filelist you posted, this looks fine.
Regarding the files I need to see, well, xorg.conf, Xorg.0.log is not really
necessary at the moment, because the framebuffer driver doesn't work
already, so I can imaging what's in your log and configuration file.

But attach them anyway, so I can have a look at them.
The output of `dmesg` also would be nice.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby daw3b » Tue Jan 30, 2007 11:37 am

tuxx-home.at wrote:The list of modules basically looks good, but tell me how you did enable them.
Have you recompiled your kernel and installed the newly created kernel
image afterwards? Simply enabling these options is not enough, you know...


yes, recompiled new kernel with option enabled into it with *, anyway some
option is enable by "m" because I cannot put * option (don't know why,I'm really using linux from 1 month).

I also don't uderstand if I have to apply some patch to the kernel, do u
have a good and working howto to link me?
thx for your help
daw3b
Private
Private
 
Posts: 5
Joined: Mon Jan 29, 2007 8:25 pm

Postby tuxx-home.at » Tue Jan 30, 2007 11:51 am

some option is enable by "m" because I cannot put * option


Well, which of them?
Basically, the system of kernel configurations follows easy rules:

If you want to enable Framebuffer Support in General and you configured
this Framebuffer Support as module, then all underlying modules will only be
allowed to be configured as modules.

In the help for each kernel configuration item you can see what it depends on
and so you should be able to see what has also to be compiled directly into
the kernel to get it working.

If you can recall, what options you haven't been able to compile into your
kernel, I will have a look and tell you what else needs to be reconfigured.

I also don't uderstand if I have to apply some patch to the kernel


No, for basic framebuffer support on the G-series cards, no kernel patch
is needed.

do u have a good and working howto to link me?


Well, not really. But there are some good kernel compile howtos on [http://tldp.org].
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby daw3b » Wed Jan 31, 2007 12:30 am

a kernel well compiled did the trick...
Insert into it the right options with "y" instead "m" and framebuffer works.
Now I have some problem with right resolution because I use ubuntu edgy and it seems to has some bug with g400, anyway this post is solved, let's read some others :D

thx a lot
daw3b
Private
Private
 
Posts: 5
Joined: Mon Jan 29, 2007 8:25 pm

Postby tuxx-home.at » Wed Jan 31, 2007 9:12 am

a kernel well compiled did the trick...


As I said :)

Now I have some problem with right resolution because I use ubuntu edgy and
it seems to has some bug with g400


That mostly depends on the mga driver you are using, but as you already said,
if the problem persists, please open up a new topic.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby daw3b » Tue Feb 13, 2007 4:06 pm

tuxx-home.at wrote:That mostly depends on the mga driver you are using, but as you already said,
if the problem persists, please open up a new topic.


problem with resolution was solved after driver update and ingoreABI option, now I'm not able to change power management options and leave TV always on also with dpms disabled as xorg and .xscreensaver files says after xset -dpms.
I'm searching over internet but no solution find yet, I'm writing again in this post because I don't understand if the problem came with fb or with mga
driver :( then dpms is also disable from bios
daw3b
Private
Private
 
Posts: 5
Joined: Mon Jan 29, 2007 8:25 pm

Postby tuxx-home.at » Wed Feb 14, 2007 3:59 pm

Well, AFAIK, DPMS can be enabled by different ways.

First, the 'Option "DPMS"' in your monitor sections is evaluated.
Afterwads, have a look at your xorg.conf and watch out for the Serverflags
section.
There are several settings regarding power saving. On my system, I have
the following options configured:

Code: Select all
Section "ServerFlags"
        Option "BlankTime" "30"
        Option "StandByTime" "45"
        Option "SuspendTime" "60"
        Option "OffTime" "120"
EndSection


For detailed information about this settings, have a look at `man xorg.conf`.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe


Return to Framebuffer Configurations

Who is online

Users browsing this forum: No registered users and 1 guest

cron