TripleHead2Go Digital with "broken" DVI Input

For questions concerning driver development in general, problems with the board or users, feature requests or other Off-Topic discussions.

TripleHead2Go Digital with "broken" DVI Input

Postby doom_fury » Fri Nov 09, 2007 5:24 am

I am attempting to make my TH2G to accept DVI input. Whenever I switch to DVI, all my monitors get an "out of range" error. This is quite strange since 75kHz/60Hz is well within specs at 1280x1024. All three monitors can accept DVI inputs and will display fine if plugged directly into the video card. Even stranger is that I can get all three to work perfectly with the exact same settings if I use VGA instead of DVI input on the TH2G. It will also display correctly using a DVI-VGA converter (DVI on the computer, VGA on the TH2G). It also works with only a single monitor plugged into the TH2G and DVI inputs.

Here is my current xorg.conf although I doubt it's an issue. It's a barebones NVidia one I am using for testing.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Wed Sep 12 14:29:17 PDT 2007

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "RenderAccel" "True"
SubSection "Display"
Depth 24

Section "Extensions"
Option "Composite" "Enable"
Posts: 1
Joined: Fri Nov 09, 2007 5:05 am

Return to General questions

Who is online

Users browsing this forum: No registered users and 1 guest