xserver version detection

For questions concerning driver development in general, problems with the board or users, feature requests or other Off-Topic discussions.

xserver version detection

Postby Manuel » Mon Jun 25, 2007 1:15 pm

Hi,

At least Debian uses a new versioning scheme for xserver (AFAIK it's also done upstream). This means your installers will display something like this:

Can't find the X Server version you are currently running (1.3.0) in
this installers database, so for your convenience, I'll try to install
the driver for the latest available version (7.1.0) onto your system.
Basically, it should be compatible to your Xorg version, so it is safe
to hit <RETURN> here.


You probably want to modify your scripts to take this into account.
Manuel
Major
Major
 
Posts: 28
Joined: Mon Jan 08, 2007 2:13 pm

Postby tuxx-home.at » Mon Jun 25, 2007 1:25 pm

I know this, but I want the script to tell the users that there are some
discrepancies between the version in the installer and the one inside the
package, because sometimes it's necessary to add the option "IgnoreABI"
to the X server because an Xorg module compiled for a different X version
will get rejected by the X server.

I do want to change the wording of the above quoted paraphrase a bit,
giving some short hints about how to circumvent this, FAQs, etc. in future
releases of the drivers.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe


Return to General questions

Who is online

Users browsing this forum: No registered users and 2 guests