Vmware-tools6.0.3 on Fedora 13

This section covers everything that is related to VMware on Linux hosts and VMs with Linux as guest OS

Vmware-tools6.0.3 on Fedora 13

Postby neakin » Sun May 30, 2010 1:51 pm

installing Vmware-tools6.0.3 on FC13 ,and the kernel version is"2.6.33.3-85.fc13.i686.PAE",
unfortunately a compilation-error occurs as follows:
-------------------------------------------------------------------------------------------------------------------------------------
Extracting the sources of the vmmemctl module.

Building the vmmemctl module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config6/vmmemctl-only'
make -C /usr/src/linux/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux'
CC [M] /tmp/vmware-config6/vmmemctl-only/os.o
/tmp/vmware-config6/vmmemctl-only/os.c: In function ‘os_init’:
/tmp/vmware-config6/vmmemctl-only/os.c:516: error: ‘struct proc_dir_entry’ has no member named ‘get_info’
make[2]: *** [/tmp/vmware-config6/vmmemctl-only/os.o] Error 1
make[1]: *** [_module_/tmp/vmware-config6/vmmemctl-only] Error 2
make[1]: Leaving directory `/usr/src/linux'
make: *** [vmmemctl.ko] Error 2
make: Leaving directory `/tmp/vmware-config6/vmmemctl-only'
Unable to build the vmmemctl module.
----------------------------------------------------------------------------------------------------------------------------------------
However,i try to use open-vm-tools to resolve it,but of no avail;
my commands are follows:
[root@localhost tmp]# cd open-vm-tools-2008.06.03 - 96374
[root@localhost open-vm-tools-2008.06.03-96374]# ./configure && make
[root@localhost open-vm-tools-2008.06.03-96374]# cd modules/linux
[root@localhost linux]# for i in *; do mv ${i} ${i}-only; tar -cf ${i}.tar ${i}-only; done
[root@localhost linux]# cd ../../..
[root@localhost tmp]# mv -f open-vm-tools-2008.06.03-96374/modules/linux/*.tar vmware-tools-distrib/lib/modules/source/
[root@localhost tmp]# cd vmware-tools-distrib/
[root@localhost vmware-tools-distrib]# ./vmware-install.pl
------------------------------------------------------------------------------------------------------------------------------------------
The error is the same as above.
Any solution?Thanks!
neakin
Private
Private
 
Posts: 1
Joined: Sun May 30, 2010 1:18 pm

Return to VMware

Who is online

Users browsing this forum: No registered users and 1 guest