Matrox drivers 1.4.7 not working with Ubuntu 10.04

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

Matrox drivers 1.4.7 not working with Ubuntu 10.04

Postby dr.kimble » Tue May 04, 2010 10:05 pm


I have a problem with the latest (official) Matrox drivers for the P series, version 1.4.7 as of May 2009.

I've been using a test installation of Ubuntu 9.10 (Linux kernel 2.6.31-20). There were several difficulties installing Linux drivers for a P650 graphics adapter, but I finally managed to get a working dual-monitor setup by tweaking the xorg.conf file. Anyway, I tried the new Ubuntu 10.04 LTS release (kernel 2.6.32-21). The driver installation failed. What I got was the normal single-screen display, but not a multi-monitor setup. I made a fresh Ubuntu installation, tried another driver install, and failed again.

It seems that Matrox' P650 drivers, version 1.4.7, don't work for this Ubuntu/kernel release any more. I'm quite new to Linux, but judging from the xorg.log file it seems that certain required modules cannot be found in the driver package.

Did anyone manage to get a working multi-monitor setup in Ubuntu 10.04 with a P-series card?

I asked Matrox support about the availability of new Linux drivers. They at present have no plans for an updated Linux driver, at least support isn't aware of any such plans.

So I'm also wondering: if this issue cannot be solved, will there be new "unofficial" drivers for the Matrox P-series?

Thanks for help.
(7.21 KiB) Downloaded 462 times
(6.85 KiB) Downloaded 481 times
(29.19 KiB) Downloaded 448 times
Posts: 4
Joined: Tue May 04, 2010 9:38 pm

Re: Matrox drivers 1.4.7 not working with Ubuntu 10.04

Postby scribe63 » Sat May 29, 2010 1:25 am

I am having the same issue, this is my story.
I scrapped my 9.04 Ubuntu Studio install, for which i had to use a AV Linux RealTime Kernel, and installed UbuntuStudio 10.04.

Besides my basic issue with the new grub2, i am currently having a serious issues with the Matrox P650 (AGP) display card.

After the initial installation, for some reason, Nautilus, Synaptic and the GNOME desktop would become unresponsive, but the mouse and keyboard would continue to work.

To solve this, I decided and installed the driver for the display card from the matrox website, of which the latest is version 1.4.7.
The installed kernel is 2.6.31-10-rt #153-Ubuntu SMP PREEMPT RT

The driver compiled without any error, but upon reboot, xserver-xorg (1.7.6)is unable to load the, glx, and v4l modules.
These are the errors it displays.
(II) LoadModule: "mtx"
(II) Loading /usr/lib/xorg/modules/drivers/
dlopen: /usr/lib/xorg/modules/drivers/ undefined symbol: resVgaShared
(EE) Failed to load /usr/lib/xorg/modules/drivers/

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/
dlopen: /usr/lib/xorg/modules/extensions/ undefined symbol: miInitVisualsProc
(EE) Failed to load /usr/lib/xorg/modules/extensions/

v4l: failed to load module, (module requirement mismatch, 0)

I am uncertain as to whether this is a Matrox, Xorg, or Ubuntu/Ubuntu Studio 10.04 issue, and the only solution seems to be a downgrade of xorg and the kernel.

Any help or insight in how to solve this issue, so as to get back my dual monitor set up, will be kindly appreciated.

Posts: 1
Joined: Sat May 29, 2010 1:11 am

Re: Matrox drivers 1.4.7 not working with Ubuntu 10.04

Postby Squonk » Fri Aug 06, 2010 9:46 pm


the trouble comes with xorg. I use Mandriva, not Ubuntu, but I think problems are the same.
Matrox support told me there are no plans for an updated driver this year, but I courageously
decided to upgrade my box from Mandriva 2010.0 to 2010.1, which means from kernel 2.6.31
to 2.6.33 and xorg 1.6.5 to 1.7.7. The mtx driver compiled and installed without error, but
did not work. I downgraded xorg back to 1.6.5, using smart and the 2010.0 RPMs, installed the
driver again, and all works fine :D .
Posts: 16
Joined: Mon Mar 17, 2008 12:43 am

Re: Matrox drivers 1.4.7 not working with Ubuntu 10.04

Postby csp » Sat Aug 21, 2010 10:47 pm

Same as discribed above: mtx 1.4.7 does not work on Ubuntu 10.04 :-(
Wrote an e-mail to matrox support.
Posts: 61
Joined: Mon Jan 01, 2007 3:03 pm

Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 2 guests