openSUSE11.0, P750 and black screen

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

openSUSE11.0, P750 and black screen

Postby Kemoauc2 » Fri Sep 04, 2009 11:48 am

Hello!
During the last weeks I attempted to get working a Matrox P750 AGP in dual monitor configuration. As often reported X comes up with a black screen and does not respond to user inputs. I tried many xorg.conf files from this forum without success. Driver is V1.4.7, 32 bit. OS version is 2.6.25.20-0.5-pae (32 bit). Hardware is Tyan S2885, 2x Opteron 250, 8 GB RAM. dmesg l grep highmem reports: Memory: 6737096k/8388608k available (...) highmem bounce pool 64 pages. Prior to this P750 I had a G450 which worked fine in Xinerama mode at 2x 1600x1200 resolution. My intention is to upgrade to a third monitor in the near future. But now I'm stuck at 1 monitor... Any suggests how to handle this issue?
Attachments
xorg.conf
(4.08 KiB) Downloaded 390 times
Xorg.0.log
(53 KiB) Downloaded 381 times
Kemoauc2
Private
Private
 
Posts: 1
Joined: Thu Sep 03, 2009 4:04 pm

Re: openSUSE11.0, P750 and black screen

Postby tomcat » Mon Sep 07, 2009 8:22 pm

Hi Kemo!

some ideas (I'm no specialist at all...)
- do you have the mtx driver and kernel module installed correctly? (Screen(s) should show "bluescreen" with Matrox Logo, when X tries to start up.) you might check with lsmod or so.
- might your X run into a timeout?
(This was my main issue: X took too long to start, so GDM killed it, thinking it would not come up... Default timeout is 10 seconds)
see here: viewtopic.php?f=2&t=875#p5369

tom.
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm


Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 3 guests

cron