[P690] PCI and [P650] AGP with Ubuntu 9.04 / Xorg 7.4 / X1.6

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

[P690] PCI and [P650] AGP with Ubuntu 9.04 / Xorg 7.4 / X1.6

Postby xdreamer » Tue Jun 09, 2009 12:44 am

Hi,

I've read the board several times and did not find the appropriate solution. Please direct me to it if I missed it. Thank you. (I've seen also http://forum.tuxx-home.at/viewtopic.php?f=2&t=719&p=4844&hilit=p690#p4844)

I had previously two graphics adapter installed at my computer, one Matrox Millenium P650 AGP and a Matrox G450 Dualhead. This worked fine so far, besides, that the Matrox G450 does not support accelerated mode during rotation is active, and the maximum resolution is limited to 1280x1024 for DVI output. So I had to connect my two other screens (both 1600x1200) to the P650.

Since I've upgraded my Ubuntu I ran into the same problems as described several times in this board. Thanks for all who provided workarounds, which after a while made my system working.

Now since the new driver has been released by Matrox, I decided to get rid of these workarounds and compiled the new driver. As reported at this forum it doesn't work for the G450, but quite well for the P650, but I had to turn on the nosplash option as a kernel option, as well as the vmalloc=256m option to increase the available memory, which wasn't necessary previously. Anyway...
Since I'm an administrator I didn't like to miss my third screen. Luckily (or not so... :( ) I found a P690 PCI graphics adapter and installed it in my system.

Now if I activate this adapter in xorg.conf configuration my X initializes the the P650 adapter until the blue matrox screens appear, or for more technical description see the log file. But hangs completely when the P690 should be activated. In the following thread a similar behavior is described, but the solutions didn't work for me, at least up to now. (http://forum.tuxx-home.at/viewtopic.php?f=2&t=528&p=3776&hilit=p690#p3776 and http://forum.tuxx-home.at/viewtopic.php?f=2&t=739&hilit=p690)

Please could anyone support me, that I have not to go through all options. My next steps would be:
  • Check the firmware of the P690 and replace it with the newest one if appropriate (Question: might it help, how to find out the current version, new linux based update anywhere (otherwise I have to use windows ... )
  • Change configuration of the xorg.conf ( I don't have any idea at the moment, which configuration options might help )
  • Check the P690 PCI card with a fresh installation somewhere
  • Any other step, which might help

What I'm wondering about:
  • The following warnings, several posts describe this, but no solution yet (as long as it works it doesn't matter ;) )
    Code: Select all
    (WW) MTX(0): Cannot read colourmap from VGA.  Will restore with default
    (WW) MTX(0): Cannot stop Matrox xform.
    (WW) MTX(0): Error occured while starting the Matrox xform.
    ...
    (WW) MTX(1): Cannot read colourmap from VGA.  Will restore with default
  • In the special case of running X with X -verbose only one monitor started, otherwise I have log entries for MTX(0), MTX(1) (P650), and MTX(2) (P690), after sending this post I try to restart the system and to produce a complete log file
  • Enabling
    Code: Select all
    Option "OCC"
    does not help besides getting rid of the message in the log file
  • What does this mean?
    Code: Select all
    (II) MTX(0): DPMS capabilities: Off
    ...
    (**) MTX(0): DPMS enabled

Startup Configuration:
Code: Select all
title      Ubuntu 9.04, kernel 2.6.28-11-generic
root      (hd1,1)
kernel      /boot/vmlinuz-2.6.28-11-generic root=LABEL=/ ro nosplash vmalloc=256m
initrd      /boot/initrd.img-2.6.28-11-generic
quiet


Note: Values for vmalloc larger than 256m do not work, does anyone know the reason?

Thank you very much in advance for your help,
Robert
Attachments
X-verbose-out.log
Failed startup (system hangs completely after last line)
(30.26 KiB) Downloaded 430 times
Xorg.0.log
Currently working configuration (2 Screens, but with inactivated mtxpci_screen)
(40.14 KiB) Downloaded 412 times
xorg.conf
(2.33 KiB) Downloaded 474 times
Last edited by xdreamer on Mon Jun 22, 2009 2:37 pm, edited 2 times in total.
xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm

Re: [P690] PCI and [P650] AGP with Ubuntu Jaunty and Xorg 1.6

Postby xdreamer » Tue Jun 09, 2009 1:27 am

Hi,

and as announced in the last post, here the complete failure log.

Note: At a first glance nothing seems unusual to me, besides the fact, that me system hangs completly after reporting the last line and blue matrox screens on both P650 screens.

Best regards,
Robert
Attachments
Xorg.0.fail.log
(48.61 KiB) Downloaded 451 times
xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm

Re: [P690] PCI and [P650] AGP with Ubuntu Jaunty and Xorg 1.6

Postby xdreamer » Wed Jun 10, 2009 1:46 pm

Ok, I tried some additional settings.

  • Tried to turn off Busmastering (also for the PCI (p690 device), but didn't change anything)
    Code: Select all
    (**) MTX(0): Option "Busmastering" "off"
    (II) MTX(0): Local Busmastering is enabled
    ...
    (**) MTX(1): Option "Busmastering" "off"
    (II) MTX(1): Local Busmastering is enabled
  • Tried to Disable dri support, as described in the Matrox readme.txt
    Code: Select all
    (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
    (II) "dri" will be loaded even though the default is to disable it.

  • Tried VESA device driver (only for the p690, but did not work due to OpenGL and GLX problems)

Has anyone experience with the comibnation of AGP and PCI Matrox graphics adapters using the "same" device driver (mtx in this special case)?

Best regards,
Robert
xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm

Re: [P690] PCI and [P650] AGP with Ubuntu Jaunty and Xorg 1.6

Postby xdreamer » Mon Jun 15, 2009 10:06 am

Hi,

had some time before weekend to test another configuration. Did the following settings:

  • Changed BIOS Option to use the PCI Card (P690) as primary device (did not remove AGP card, but deactivated it in the xorg.conf) (Result: PCI graphics adapter works only with VESA driver, using the mtx driver the adapter freezes computer as observed before)
  • Using the changed BIOS configuration and the VESA driver for p690 and activating the mtx (1.4.7) drivers for the p650 works as well.

Question: What might be wrong with the combination of the mtx driver and the p690 PCI card?
I appended only the working log file, because the the one logged while failure has no differences to the previous posted ones, besides the fact, that only the pci device is enabled. (The miPointer errors are annoying, but discussed in the Ubuntu forums...)

Best regards,
Robert
Attachments
Xorg.0.p690vesa-p650mtx.log
(113.17 KiB) Downloaded 423 times
xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm

Re: [P690] PCI and [P650] AGP with Ubuntu Jaunty and Xorg 1.6

Postby xdreamer » Mon Jun 15, 2009 3:37 pm

Now it becomes a little bit weird.

Before lunch I tested the following options:

  • Removed AGP card completely (Result: mtx driver still freezes system, vesa driver works (most of the time))
  • Adding kernel module options agp=0 without AGP graphics adapter installed leads also to a complete system freeze

So for now I'm going to remove the card until a new idea arrives.

Best regards,
Robert
xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm

Re: [P690] PCI and [P650] AGP with Ubuntu Jaunty and Xorg 1.6

Postby xdreamer » Tue Jun 16, 2009 12:06 am

Hmm found this bug reports for Ubuntu, maybe they are related to my problem, esp. the first one.

xdreamer
Private
Private
 
Posts: 8
Joined: Mon Jun 08, 2009 9:49 pm


Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 5 guests

cron