Unable to get dual display with Parhelia 128

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

Unable to get dual display with Parhelia 128

Postby roloman » Sat Mar 14, 2009 1:48 am

Having trouble getting my Parhelia 128 into dual display with KDE 4.1.

Intel P4 3.0 GHz
Abit IC7-G mobo, 1G RAM
Matrox Parhelia 128 video card
NEC MultiSync FP2141SB (2 monitors)
Debian Lenny (locally compiled kernel to ensure appropriate video modules enabled)

Have read several HOWTOs and looked over this forum but still no luck.

Downloaded and installed the latest mtx driver (1.4.6.2). Updated Parhelia BIOS (sysutil_pm200_04_003: 971-22.bin). Manually changed xorg.conf based on HOWTOs. Restarted X (ctrl+alt+backspace).

The mtx driver seems to load (blue Matrox splash screen). Initially I did not specify a default color depth (nor modes) in the xorg.conf and KDE defaulted to 8 bit color depth (in single screen). KDE seemed to function normally but as you can imagine, it looked horrible. When I specify a default color depth and modes, Kwin crashes. At no time did the second screen ever come up.

xorg.conf and Xorg.0.log attached.

Can anyone help?
Attachments
Xorg.0.log
(41.82 KiB) Downloaded 383 times
xorg.conf
(2.3 KiB) Downloaded 404 times
roloman
Private
Private
 
Posts: 4
Joined: Sat Mar 14, 2009 1:18 am

Re: Unable to get dual display with Parhelia 128

Postby tuxx-home.at » Sat Mar 14, 2009 10:48 am

I did now assume that both monitors are the same and for the start, let's try 1280x1024 on both monitors. We can try to increase the resolution once that worked.
Please try the attached configuration file.
Attachments
xorg.conf
MergedFB Setup for dual 1280x1024
(1.95 KiB) Downloaded 382 times
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: Unable to get dual display with Parhelia 128

Postby roloman » Sat Mar 14, 2009 5:05 pm

tuxx-home.at wrote:I did now assume that both monitors are the same and for the start, let's try 1280x1024 on both monitors. We can try to increase the resolution once that worked.
Please try the attached configuration file.


I tried the config file you suggested but got the same result. I get the blue matrox splash screen but when KDE tries to launch, Kwin crashes. Xorg.0.log attached.

Changed the default color depth from 24 to 16, same result. Xorg.0.og-2 attached.

And yes, both monitors are identical (NEC MultiSync FP2141sb).

For reference, the working xorg.conf and associated Xorg.0.log are attached (xorg.conf-default and Xorg.0.log-default).

My backup plan is to abandon this Parhelia card and spend $60 bucks on an Nvidia GForce 6200 twin screen. But I really don't want to spend any money on this since this rig is 5 years old and I plan on upgrading to a quad core machine in about a year.

Thanks for any advice you can give.
Attachments
Xorg.0.log
(60.82 KiB) Downloaded 412 times
roloman
Private
Private
 
Posts: 4
Joined: Sat Mar 14, 2009 1:18 am

Re: Unable to get dual display with Parhelia 128

Postby roloman » Sat Mar 14, 2009 5:18 pm

Well, I see there are certain restrictions on uploaded file names and limits on post length so here is the log file with DefaultColorDepth=16.
Attachments
Xorg.0.log
(60.78 KiB) Downloaded 398 times
roloman
Private
Private
 
Posts: 4
Joined: Sat Mar 14, 2009 1:18 am

Re: Unable to get dual display with Parhelia 128

Postby roloman » Sat Mar 14, 2009 5:20 pm

For reference, here is the working xorg.conf and associated log file.
Attachments
Xorg.0.log
(59.29 KiB) Downloaded 411 times
xorg.conf
(1.95 KiB) Downloaded 427 times
roloman
Private
Private
 
Posts: 4
Joined: Sat Mar 14, 2009 1:18 am


Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 5 guests

cron