dual 1680 x 1050 in portrait mode

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

dual 1680 x 1050 in portrait mode

Postby piers » Thu Jan 29, 2009 9:46 pm

Hi Alexander et al.

I'm currently using a P650 with dual 1680x1050 screens in landscape mode and now want to do the same but in portrait mode. (v 1.4.5.1 32bit intel).

I added the rotation statement Option "Rotate" "CW" # CW = clockwise, CCW = counter-clockwise to each screen section in the xorg.conf.

However I can only get both screens in portrait mode at 1280x1024 or just one screen at 1680 x 1050.

In the Xorg.0.log.old file attached, i notice the error "(II) MTX(0): Largest offscreen area available: 1050 x 840" perhaps this has something to do with the problem but i'm not sure.

Please could you offer some help?

thanks
Piers
Attachments
xorg.conf
(2.81 KiB) Downloaded 368 times
Xorg.0.log.old
(55.31 KiB) Downloaded 380 times
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London

Re: dual 1680 x 1050 in portrait mode

Postby tuxx-home.at » Thu Jan 29, 2009 9:49 pm

Could you please try to reproduce that with the latest available driver?

[http://projects.tuxx-home.at/mtx/drivers/latest/]
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: dual 1680 x 1050 in portrait mode

Postby piers » Thu Jan 29, 2009 11:05 pm

Upggraded the driver to 1.4.6.2

i get the same problem as before. I notice the follwing error below in Xorg.0.log.2

(WW) MTX(1): Cannot use Parhelia module for acceleration, device failed to start with error code 8.

thanks
Piers
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London

Re: dual 1680 x 1050 in portrait mode

Postby piers » Thu Jan 29, 2009 11:11 pm

Upggraded the driver to 1.4.6.2

i get the same problem as before. I notice the follwing error below in Xorg.0.log.2

(WW) MTX(1): Cannot use Parhelia module for acceleration, device failed to start with error code 8.

thanks
Piers
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London

Re: dual 1680 x 1050 in portrait mode

Postby piers » Thu Jan 29, 2009 11:15 pm

Upggraded the driver to 1.4.6.2

i get the same problem as before. I notice the follwing error below in Xorg.0.log.2

(WW) MTX(1): Cannot use Parhelia module for acceleration, device failed to start with error code 8.

thanks
Piers
Attachments
Xorg.0.log
(55.04 KiB) Downloaded 389 times
piers
Sergeant
Sergeant
 
Posts: 15
Joined: Sun Jan 21, 2007 10:59 pm
Location: London

Re: dual 1680 x 1050 in portrait mode

Postby tuxx-home.at » Mon Feb 02, 2009 4:02 pm

Try to load the mtx kernel module with the parameter "regSysMmFlags=0", you may need to add that to your /etc/modules or /etc/modprobe.d/* files, depending on your distribution.

For testing purposes, simply boot without the grahpical interface or wait for the error to occur, then, switch back to the console and enter:

Code: Select all
rmmod mtx
modprobe mtx regSysMmFlags=0


Would be interesting to see if that helps.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe


Return to Matrox P-Series Cards

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron