Latest driver version is mtx 1.4.6.2

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

Latest driver version is mtx 1.4.6.2

Postby tuxx-home.at » Sun Jan 14, 2007 10:07 pm

This is an announcement thread.
You may watch this thread to get notified about driver updates automatically.

Topic link to 1.4.6.2

[http://forum.tuxx-home.at/viewtopic.php?t=3]
Last edited by tuxx-home.at on Tue Oct 23, 2007 10:43 am, edited 9 times in total.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

2.6.20-rc

Postby dejfrcr » Fri Feb 02, 2007 4:55 pm

I found a problem with 2.6.20-rc6-mm2 (and probably above), made by removing just another symbol. I mailed with tuxx-home.at and got this patch:

--- mtx_irq.c.orig 2007-02-02 12:53:12.000000000 +0100
+++ mtx_irq.c 2007-02-02 12:53:30.000000000 +0100
@@ -75,7 +75,7 @@

/* Request IRQ line */
/* TODO fix the sharing problem*/
- ret = request_irq(dev->pci_dev->irq, mtx_irq_interrupt, SA_SHIRQ, GetPciName(dev->pci_dev), dev);
+ ret = request_irq(dev->pci_dev->irq, mtx_irq_interrupt, IRQF_SHARED, GetPciName(dev->pci_dev), dev);

if (ret < 0)
{

---- it works with 2.6.20-rc6-mm2 and I'm going to porbe rc6-mm3 and rc7-git1, will make it's way to 1.4.4.5, but if somebody needs it now, I placed it here. Just put it in the kernel/src folder and run echo 'the patch I placed here' | patch or put it in file and run patch < file

Thank you again Alex
User avatar
dejfrcr
Private
Private
 
Posts: 8
Joined: Fri Feb 02, 2007 1:26 pm
Location: Prague - Czech Republic - Europe

tested

Postby dejfrcr » Fri Feb 02, 2007 5:41 pm

so the new patch works with 2.6.20-rc6-mm3 and 2.6.20-rc7-git1, the two most bleeding edge versions of kernel. I hope, the final 2.6.20 would behave same way...
Attachments
2.6.20-for mtx1444.diff.gz
The diff from Alex in form of file.
(272 Bytes) Downloaded 758 times
User avatar
dejfrcr
Private
Private
 
Posts: 8
Joined: Fri Feb 02, 2007 1:26 pm
Location: Prague - Czech Republic - Europe

Postby tuxx-home.at » Fri Feb 02, 2007 7:26 pm

Hey guys, you're awesome :) Thanks for updating the information here.
This weekend I'm moving to my new flat and approximately on wednesday
next week, 1.4.4.5 will be out for those of you who aren't experienced enough to patch things up to make them work :)

In the meantime, thanks for posting it here!
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

instability with 2.6.20-rc6-mm3

Postby dejfrcr » Sat Feb 03, 2007 9:09 pm

the Xwindow system alltogether is slightly unstable with this kernel. It freezes and the only way out is Alt-PrnScr-E, which completely turns off all services in a bit unfriendly matter. But saves the reset button :)
After return by startx it works again for some hours. It may be problem of the kernel itself (-mm is not stable, it's experimental), but it may be also based on incompatibility with the matrox driver, so we might expect some problems in future, because I suspect the 2.6.20-rc7-git to behave the same way, but I used it only for shorter time. I'm going to reboot to test it. I never got this problem before, and the only changed thing is kernel and that little patch in the driver.
User avatar
dejfrcr
Private
Private
 
Posts: 8
Joined: Fri Feb 02, 2007 1:26 pm
Location: Prague - Czech Republic - Europe

2.6.20-rc6-mm3 problem continued

Postby dejfrcr » Sat Feb 03, 2007 11:22 pm

I found some problem when communicating with my software raid with that kernel, without any messages from kernel, but waiting for acces forever. That may be the reason for X freezes even while X does not acces that partition, thats just for data. Who knows?
I rebooted to rc7-git1 and it is running now, I'll see in some hours.
User avatar
dejfrcr
Private
Private
 
Posts: 8
Joined: Fri Feb 02, 2007 1:26 pm
Location: Prague - Czech Republic - Europe

still running without problems on rc7-git1

Postby dejfrcr » Sun Feb 04, 2007 4:10 am

git3 is already compiled, I'll boot it tomorow and see. Problems were probably caused by the -mm kernel. I'm goin to sleep now :)
User avatar
dejfrcr
Private
Private
 
Posts: 8
Joined: Fri Feb 02, 2007 1:26 pm
Location: Prague - Czech Republic - Europe

2.6.20-rc7-git3 and probably final are compatible.

Postby dejfrcr » Tue Feb 06, 2007 12:28 am

Hello again,
I'm running 2.6.20-rc7-git3 (which is almost the final 2.6.20) with the patched version of mtx-1.4.4.4 for the whole day without a single problem.
It works, thanks again to you Alex
User avatar
dejfrcr
Private
Private
 
Posts: 8
Joined: Fri Feb 02, 2007 1:26 pm
Location: Prague - Czech Republic - Europe

Postby tuxx-home.at » Wed Feb 07, 2007 4:54 pm

OK, I'm currently building a installable package. Will be up in about 20 minutes.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby tuxx-home.at » Thu Feb 08, 2007 2:44 pm

*bump*

Another update, raising the available version to 1.4.4.6 :)
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

And was there 1.4.4.5?

Postby dejfrcr » Mon Feb 12, 2007 10:37 am

Looks like you made a version jump. Why?
User avatar
dejfrcr
Private
Private
 
Posts: 8
Joined: Fri Feb 02, 2007 1:26 pm
Location: Prague - Czech Republic - Europe

Postby tuxx-home.at » Mon Feb 12, 2007 11:12 am

No, I didn't. 1.4.4.5 was available, see here for the release notes:

http://tuxx-home.at/archives/2007/02/07/T16_42_26/

But as 1.4.4.6 was available just a few days later, 1.4.4.5 wasn't that
popular.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby tuxx-home.at » Fri Feb 16, 2007 10:04 am

*bump* - 1.4.4.8 is there.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby harvey186 » Thu Apr 19, 2007 6:21 pm

tuxx-home.at wrote:*bump* - 1.4.4.8 is there.


Hi tuxx-home.at, I'm happy, that someone (you) is working on a driver for my Parhelia DCL256 PCI. I'm using Fedora 6 and I want using the full digital resolution of 1920x1200 and I want enable the Beryl desktop (3D). But in the moment I only get 1600x1200 and no desktop effects. When I install the driver 1.4.4.8 I get the following message:
========================================
Matrox Linux Driver Install Script
========================================
Installing X server driver for X.org 7.1.0
Installing V4L driver for X.org 7.1.0
Messages are being logged in file /tmp/make.log,
this might take some time.
Compiling mtx.ko ...
ERROR: There has been an error compiling the kernel module.
A log file has been created in the file /tmp/make.log
The program returned an error code (1)

What can I do ?
Thanks Harvey
... sorry for my bad english and I'm a absolut Newbee with Linux. If you need additional informations from me, please descripe my step by step what I have to do. Thanks
Attachments
make.log
(5.16 KiB) Downloaded 711 times
harvey186
Major
Major
 
Posts: 45
Joined: Thu Apr 19, 2007 5:49 pm

Postby tuxx-home.at » Sat Apr 21, 2007 5:53 pm

make: *** /lib/modules/2.6.20-1.2944.fc6/build: Datei oder Verzeichnis nicht gefunden. Schluss.


This is the error message that breaks building.
It means, that the symbolic link mentioned above does not link to the kernel
source directory. This is usually the case when the kernel sources are not
installed on your system.

You may check the target of the symlink with the following command:

Code: Select all
file /lib/modules/2.6.20-1.2944.fc6/build


Usually, the resulting output should be something like "/usr/src/linux-2.6.20-1.2944.fc6".
Check, if this directory exists on your system and if it doesn't, install
the kernel-sources package with the help of your distributions package
management tools.

Afterwards, it should be possible to change into the build directory with
the command `cd` as shown in this example, without an error message
given:

Code: Select all
cd /lib/modules/2.6.20-1.2944.fc6/build


Currently, this is not possible on your system and therefore the Makefile
fails.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Next

Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 2 guests

cron