OpenGL programme causes system hang

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

OpenGL programme causes system hang

Postby myfanwy » Thu Jul 05, 2007 1:35 am

Hi, I'm trying to run a couple of OpenGL programmes, and whenever they start the system hangs. The mouse will move, but i can't click anything the, kb does nothing and even Ctrl-Alt-Bksp and Ctrl-Alt-F1 do nothing.

The same problem occurs when I run glxgears and glxinfo.

I am using the newest driver, and have tried re-installing using the --overwrite switch, which complete fine with no error messages. I have also tried manually copying the libglx.so file as described in http://matrox.tuxx-home.at/viewtopic.php?t=37

I have run the depmod and modprobe mtx commands, and lsmod tells me mtx is loaded

Thank you
myfanwy
Sergeant
Sergeant
 
Posts: 16
Joined: Sat Jan 27, 2007 4:39 am
Location: Auckland, New Zealand

Postby tuxx-home.at » Fri Jul 06, 2007 1:18 pm

Have you already tried the following hint out of the readme?

Code: Select all
Q:  My system seems to lock up when I try to run a video or OpenGL application.
    What can I do ?
A:  Try disabling fastwrites in your motherboard BIOS settings. Also, in some
    systems with 1GB of RAM or more, you need to pass the following switch
    (vmalloc=) to your boot manager (in grub on the appropriate kernel line or
    in lilo on the append line. Note that the ram value passed is in bytes).
    For example, if you want to reserve at least 128MB, you add this to your
    boot manager config file:

        vmalloc=134217728



I've set up a FAQ entry for a simliar problem, maybe it helps:

[http://matrox.tuxx-home.at/viewtopic.php?t=34]
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe


Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 2 guests

cron