P750 Ubuntu prob

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

Postby tuxx-home.at » Thu Jun 14, 2007 8:31 am

Thanks, will try this but doesn't this above code just list the swap files?


Yes, it does. I don't like posting `rm` commands without knowing what files
are there to be deleted.
If you can see .*sw* files in this directory, they can definetly be deleted.

Neither can any open prog be dragged across one to the other.
The only thing that can be is the mouse


Alright, then it is _NOT_ a clone and adding the Xinerama option to your
xorg.conf should do the rest.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby derf » Thu Jun 14, 2007 9:49 am

Managed to delete the 3 .*sw* files , re-opened xorg.conf,tried to add the Xinerama lines but could not (again!) save it using vim.

However, i then remembered your other suggestion of using 'nano' so searched for these commands on the ubuntu community docs - using nano this time i managed to edit and save your Xinerama settings.

Re-opened xorg.conf to check, this time using vim, and it has saved correctly.

However, you did not say exactly where to place the 'Option Xinerama On' section ... after monitors, or before or after "ServerLayout", or where exactly?

...nor what to do now it is in the xorg.conf re: Xinerama

You also suggested changing the "ServerLayout" lines for the screens to become how do say indepentant and not clone, not sure terminology here
but did not say to what this should be changed to.

What should this section now say?

It says:

Code: Select all
Section "ServerLayout"
              Identifier            "Default Layout"
              Screen                "Screen 1"
              Screen                "Screen 2" RightOf "Screen 1"
              InputDevice       "Generic Keyboard"
              InputDevice       "Configured Mouse"
              InputDevice       "stylus"                   "SendCoreEvents"
              InputDevice       "cursor"                   "SendCoreEvents"
              InputDevice       "eraser"                   "SendCoreEvents"
EndSection
derf
Major
Major
 
Posts: 27
Joined: Sun Jun 10, 2007 8:25 am

Postby tuxx-home.at » Thu Jun 14, 2007 9:57 am

Managed to delete the 3 .*sw* files


Good.

but could not (again!) save it using vim.


You should do some dry-runs with vim to learn how to use it ;)

However, you did not say exactly where to place the 'Option Xinerama On'
section .


I did. I said put it in the ServerFlags section and if it doesn't exist,
create it (as in the example shown on the previous page). Additionally,
I said that the order of the sections in the file is not important, so you
can basically put it anywhere.

The ServerLayout section looks fine.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby derf » Thu Jun 14, 2007 10:00 am

Addendum:

restarted, and Screen 2 is now_NOT_a clone, and i can drag, open, from both one to the other and back again etc. just like i used to be able to do under M$

Many, many thanks - expect a small donation for your patient expertise via your PayPal soonish :D (i'm not employed so don't get your hopes up too high, it wont be much but some beer is better than no beer, eh?!)

Is that all we need to do for the moment?

Or is there some more 'house-keeping' tasks?
derf
Major
Major
 
Posts: 27
Joined: Sun Jun 10, 2007 8:25 am

Postby tuxx-home.at » Thu Jun 14, 2007 10:06 am

restarted, and Screen 2 is now_NOT_a clone, and i can drag, open, from both
one to the other and back again etc. just like i used to be able to do under M$


Great!!

expect a small donation for your patient expertise


Many thanks!

Is that all we need to do for the moment?
Or is there some more 'house-keeping' tasks?


You could finally attach the xorg.conf and Xorg.0.log files to your next
post so that I can have a look if there are some cosmetic things left to do.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby derf » Thu Jun 14, 2007 10:31 am

Done!
Attachments
Xorg.0.log
(52.03 KiB) Downloaded 230 times
xorg.conf
(3.34 KiB) Downloaded 258 times
derf
Major
Major
 
Posts: 27
Joined: Sun Jun 10, 2007 8:25 am

Postby tuxx-home.at » Thu Jun 14, 2007 10:46 am

Looks good, despite some error messages about missing input devices
(wacom a.s.o.), but that doesn't affect performance.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby derf » Thu Jun 14, 2007 11:48 am

tuxx-home.at wrote:Looks good, despite some error messages about missing input devices
(wacom a.s.o.), but that doesn't affect performance.


Glad it "looks" OK to you (i have no idea)

But, performance or otherwise, will it/should it be necessary to fix whatever is missing?

Exactly "what" performance is affected by not fixing and "how" should one go about fixing whatever "it" is?
derf
Major
Major
 
Posts: 27
Joined: Sun Jun 10, 2007 8:25 am

Postby tuxx-home.at » Thu Jun 14, 2007 11:53 am

Don't worry, just leave it as it is :)
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Previous

Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 2 guests

cron