Migrating from Matrox P690 to ATI Radeon (Ubuntu 10.04 LTS)

This forum is for all Parhelia based cards (Millenium P650, P690, P750, QID, Parhelia 256, APVe, ...) that need the mtx driver to run properly.

Migrating from Matrox P690 to ATI Radeon (Ubuntu 10.04 LTS)

Postby tomcat » Mon Jul 12, 2010 6:01 pm

Hi !

This post and the next few posts refer to upgrading a driver on an existing installation to the proprietary ATI driver.
For the procedure on a fresh ubuntu install, see the post titled "Fresh Install ATI Radeon (Ubuntu 10.04 LTS)" in this thread.
viewtopic.php?f=2&t=1215&p=6089#p6327

<brain-dump confusing=true>
I was a happy Matrox User until I upgraded to Ubuntu 10.04 LTS a few days ago. Instead of just recompiling, I got the error-messages that are already described in other posts (which I should have read beforehand :-().
After some google searching I decided to dump the Matrox P690 Card(s) and go for a cheap ATI Radeon.

Old setup:
- 2x P690 (1x PCIe x16, 1x PCIe x1) with DVI connectors.
- 3x DVI LCD Screens.
New Setup:
- 1x ATI HD 4350 with DVI and HDMI Port
- 1x HDMI to DVI 2meter cable.
- 2x DVI LCD Screens.

Basic Procedure, YMMV: (See other docs, but maybe this helps to ease the switch for you.)

- select card: Multiple Vendors, multiple Hardware/CPU versions, multiple interfaces (DVI, HDMI, Displayport etc.)
- I got a DVI/HDMI Combo card. That one required a HDMI to DVI converter cable (EUR 10,-) to be used with two DVI screens.
It is passively cooled, so no extra fan in the box. But it is two slots wide! Make sure it fits inside your box.
- Download the latest Matrox Drivers beforehand.
- Install RTFM (http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide) for proprietary driver.

- What is different:
- don´t manually mess around with the xorg.conf!
- on ATI, xorg.conf is built/created via the "aticonfig" program that will be installed together with the driver.
- "aticonfig -f --initial=dual-head --screen-layout=right --tls=1 --xinerama=on" is 90% of what you need for a dual-head setup.
-f: override xorg.conf (may need a rm -f xorg.conf before anyway.) --initial: create from scratch --initial=dual-head create for dual-head.
- "aticonfig -h" is the help screen for details, very long...
- ati has its own "registry" in /etc/ati/amdpcsdb This file contains additional settings that will be loaded by the driver but that are not in xorg.conf. Sometimes this amdpcsdb needs to be updated when X is not running to be effective.
- also there is a "default" copy in /etc/ati/amdpcsdb.default. I read somewhere (didn´t try), that sometimes you may want to delete the amdpcsdb, copy the .default to the basic version an re-apply the aticonfig settings again.
- I needed to set a different Video Output in Mplayer.
- they have a new 2d Accelerator, configuring it is described in the cchtml wiki-page. I did not manage to disable the old accelerator - will give it a try on my next ATI-driver reinstall. (Probably I played around too much with the setup when I didn´t have dual-head working.)

Issues/Problems:
- Initial setup w/o dual-head but with two screens that were cloned, the display and scrolling in Firefox etc was terribly slow and buggy. (Here I probably screwed up on the amdpcsdb settings). After I got the dual-head xorg.conf right, everything worked fine.

Compared to my first Matrox-setup this one was a piece of cake.

Reinstalling the ATI-Driver (Version update) seems to require a "full kill" of the existing files. (All documented in the wiki above.)

For multiple cards: What I found (but didn´t test): use "aticonfig -f --adapter=all --initial=dual-head" to get all adapters for the dual-head setting... YMMV.
</brain-dump>

Bye Bye Matrox on Linux. Those two boards will probably end up on Ebay.
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm

Some more infos

Postby tomcat » Wed Jul 14, 2010 7:38 pm

Some more infos:
- I am not using Compiz.
- Set up/install proprietary catalyst driver as described in cchmtl-wiki
- I scrapped my old driver config by copying /etc/ati/amdpcsdb.default to amdpcsdb and started from scratch:
- configure driver: (as root or use sudo)
0) remove xorg.conf and/or backup existing.
1) aticonfig -f --initial=dual-head --screen-layout=right --tls=1 --xinerama=on
2) aticonfig -f --set-pcs-str="DDX,EnableRandR12,FALSE"
3) aticonfig -f --set-pcs-str="DDX,Direct2DAccel,TRUE"
4) aticonfig --input=/etc/X11/xorg.conf --tls=1
(reboot)
5) Add other config parameters: see attached xorg.conf

After making any manual changes to the xorg.conf, it has to be "reloaded" into AMDs own "registry" (/etc/ati/amdpcsdb) by submitting the "aticonfig --input=/etc/X11/xorg.conf --tls=1" command. This command will re-write / re-sort the xorg.conf as well. Then restart X or reboot.

Ubuntu Kernel Boot Parameter Setting:
[url]https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#Working%20around%20bugs%20in%20the%20new%20kernel%20video%20architecture
[/url]

Further parameters for xorg.conf can be found and are discussed here:
http://forum.compiz.org/viewtopic.php?f=114&t=6794&sid=6b443faa61805424660094c255cfb36e

Video-Settings are discussed here:
http://blog.mageprojects.com/2010/06/17/ati-vsync-without-video-trearing-works/

/* Edit: See posting further down - freezing is gone now.
Current Issue: Sometimes X / the machine freezes with the mouse cursor trapped on the border between the two screens. Maybe I need to tweek some more parameters in xorg.conf.
*/
Attachments
xorg.conf
current xorg.conf
(1.86 KiB) Downloaded 756 times
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm

Replaced the video card from HD 4350-PCI to HD 5570 PCIe x16

Postby tomcat » Thu Jul 15, 2010 5:37 pm

Replaced the ATI HD 4350 PCI with a HD 5570 PCIe x16 Board.
Now most/all of the flicker, tearing etc. is gone due to (probably) better board performance and higher bus speed.

Procedure:
- replace board
- boot to single user
- "lspci" for determining the new PCI bus location PCI:1:0:0 (from PCI:3:0:0)
- modify xorg.conf (in two places ;-)
- "aticonfig --input=/etc/X11/xorg.conf --tls=1"
- reboot

/* Edit: See next post - freezing is gone now.
We´ll see if the freezing still persists (this only happens rarely when moving the mouse pointer from one screen to the other, when it gets stuck in the middle between those two screens and the only solution is to reset the machine.)
*/
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm

Freezing seems to be gone

Postby tomcat » Tue Jul 20, 2010 9:15 pm

:D After two days of heavy usage and two more days of "normal" usage, there was no freeze-event (knock on wood...).
The system seems to be stable now.

Guess: The problem may have been some bad timing somewhere in conjunction with the "slower" graphics card.
(Besides switching the graphics card I didn´t do any other modifications since the last freezer...) :D

Update 2010.10.04: Recently I had one single Freeze-Event.
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm

Ubuntu 10.04 LTS now officially supported by ATI

Postby tomcat » Tue Jul 27, 2010 6:55 pm

With the release of the 10.7 ATI driver, ubuntu 10.04 is fully supported ("production").

Also Eyefinity support is now there. (for ATI Eyefinity cards, where you can have 2+ Screens (up to 6?) attached to a single board. Beware that for more than 2 screens a screen with a Display Port connection is required. (Or an ACTIVE display port converter - which is around EUR 100).)

Announcement from ATI for the 10.7 driver is here: http://blogs.amd.com/play/2010/07/26/ati-catalyst%E2%84%A2-10-7-driver-%E2%80%93-what%E2%80%99s-new/

I don´t know, if or when I will upgrade to this driver. I am fine with the current configuration.

Stability update: No issues. No hiccups, no problems. System is stable. :D
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm

Updating to latest driver required after Kernel-Update

Postby tomcat » Mon Oct 04, 2010 7:44 pm

With the 2.6.32-25 Kernel release, the catalyst (= proprietary driver) would not auto-build any more due to some changes in the kernel. AMD released a hotfix for this: http://support.amd.com/us/kbarticles/Pa ... otfix.aspx

(After a detour with some intermediate and ubuntu-supplied driver/patches - which had trouble refreshing the screen and didn´t live up to my expectations, I re-installed the original driver with the patch from ATI.)

Due to all the hiccups inbetween (and as documented for updating the driver), the old driver had to be purged completely and before any new stuff could be installed.
I combined & mixed the purging info from

Thereafter the re-install of the driver as described in http://wiki.cchtml.com/index.php/Ubuntu ... st_package. went ok.

A re-install of the xorg.conf was not required. Just rebooted and bam - it worked fine again.
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm

Fresh Install ATI Radeon (Ubuntu 10.04 LTS)

Postby tomcat » Mon Apr 04, 2011 2:31 pm

Due to the Harddisk being 5 years old - almost to the day, I decided to buy and install a new disk before the old one dies...
So I installed Ubuntu 10.04 LTS from scratch - together with the ATI driver.

Config:
- 1 ATI Radeon HD 5500 Series
- 2 Screens, 1 connected via DVI, one via HDMI

Setup-Procedure:
(similar to the description in the cchtml wiki: http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide)
- install new Ubuntu from Scratch (all default...)
- installation runs fine, after reboot screens are blank.
- connect one screen to the VGA output of the graphics card.
- enable restricted /proprietary drivers
- run find new hardware and enable the ATI driver.
- have the system download and install the proprietary ATI driver.
- reboot
- switch the connector back to DVI
- have both screens working ;-)
- configure via System-> Preferences -> ATI Catalyst Control Center (Administrative)

That's about it. No more trouble with xorg.conf etc. The only issue I am currently having: The Background Image with a size of 3820x1200 is not spanning across both screens. But I think I can live with that... :-)

Summed up: This was the easiest Graphics Card Software install I ever had on a Linux-Box!
tomcat
Sergeant
Sergeant
 
Posts: 17
Joined: Thu Aug 20, 2009 7:54 pm


Return to Matrox P-Series Cards

Who is online

Users browsing this forum: No registered users and 4 guests