Kernel 2.6.29 + client 4.81.0640 causes crash

Installation, configuration and troubleshooting of the Cisco VPN Client on Linux systems

Kernel 2.6.29 + client 4.81.0640 causes crash

Postby Zarhan » Fri Apr 03, 2009 11:43 am

Hi,

Any patch to remedy this issue yet?

Use kernel 2.6.29.
Using previous patches makes compilation go ok, no problems.
Connect using Cisco VPN client - log in works fine.
Transfer ANY traffic over the vpn (even just a ping) causes crash (kernel panic).

This issue is not present in 2.6.28.

On a similar note, a more long-standing issue is that if using Cisco VPN over ppp interface and the interface vanishes (e.g. cellular connection goes down => ppp0 is removed) I also get kernel panic. Any ideas for that? This has been a prob as long as I've been using the client in Linux.
Zarhan
Private
Private
 
Posts: 1
Joined: Fri Apr 03, 2009 11:39 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby mawk » Sun Apr 05, 2009 1:29 pm

Hi there,

yes, I confirm this issue! situation shows as follows:
- using debian lenny + kernel-2.6.29-1-486 + kernel header files matching the running kernel
- vpn-install works fine without any error, kernel module loads fine too;
- connect to my companies network works fine too;
- whatever I do then eg. ping a server or ssh to a server freezes my system immediately
keylock + roll lamps are blinking
- nothing in the log files except
Apr 5 11:51:51 nmb kernel: [ 361.959313] cisco_ipsec: module license 'Proprietary' taints kernel.
Apr 5 11:51:51 nmb kernel: [ 361.961437] cipsec0 (): not using net_device_ops yet
Apr 5 11:51:51 nmb kernel: [ 361.962548] Cisco Systems VPN Client Version 4.8.01 (0640) kernel module loaded

Hope there is somebody out there who is able to fix this.

Thanks in advance...

Regards,
mawk
mawk
Private
Private
 
Posts: 1
Joined: Sun Apr 05, 2009 12:27 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby torel » Tue Apr 07, 2009 9:07 am

Seeing the same thing on kernels above 2.6.28.

# modinfo cisco_ipsec
filename: /lib/modules/2.6.29.1-46.fc11.x86_64/CiscoVPN/cisco_ipsec.ko
license: Proprietary
depends:
vermagic: 2.6.29.1-46.fc11.x86_64 SMP mod_unload

# ls -la /opt/Cisco/vpnclient-linux-4.8.01.0640-k9

Kernel module loads fine. When using the tunneling device, system hangs. Will install kdump+debug kernel, and see if I can get a dump.
torel
Private
Private
 
Posts: 1
Joined: Tue Apr 07, 2009 9:02 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby jprobichaud » Wed Apr 15, 2009 12:37 pm

I'd like to add myself to the "me too" group (system halt + blinking lights). I'm having the same issue, although with a different version of the client: 4.8.00.0490. It's working flawlessly with 2.6.28, but with 2.6.29, as soon as I send traffic over, my laptop hangs.

I'm using Gentoo, with the tuxonice-sources for the kernel.

Let me kknow if/how I can help.
jprobichaud
Private
Private
 
Posts: 1
Joined: Wed Apr 15, 2009 12:30 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby WladyX » Fri Apr 17, 2009 12:04 pm

I get this too on Arch linux. Any solutions/workarounds so far?
Thanks.
WladyX
Private
Private
 
Posts: 1
Joined: Fri Apr 17, 2009 12:03 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby linux4guru » Fri May 01, 2009 7:53 pm

Hello,

I hope this help... I was playing with it last night and got Ubuntu 9.04 x64 working with Kernel 2.6.29 with client 4.8.1.0.640.

Here are the steps I did...

1. apt-get install make (I don't think the default install make - probably not require to install....)
2. apt-get install kernel source
3. apt-get install gcc (could be option - ??? again not sure if you needed.)
4. download the 2.6.24 diff patch and apply that to the 4.8.1.0.640 - it works for me...
5. now, install the cisco vpn client. compile fine and have tested vpn connection last night.


Cheers!

thomas
linux4guru
Private
Private
 
Posts: 1
Joined: Fri May 01, 2009 7:48 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby mariuszs » Wed May 20, 2009 7:17 am

I have this same on Fedora11, Kernel panic after ping to remote host, and message in log about bad RIP?

@linux4guru, are you sure? Ubuntu 9.04 have older kernel.
mariuszs
Sergeant
Sergeant
 
Posts: 18
Joined: Wed May 20, 2009 6:59 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby tuxx-home.at » Wed May 20, 2009 3:12 pm

Have you guys tried to switch off one CPU as mentioned in the sticky?

viewtopic.php?f=15&t=457

Please grab the latest client version from http://projects.tuxx-home.at/ciscovpn/c ... ux/4.8.02/ and try again (I have updated the package but not changed the version number, so even if you already downloaded this package, please download it again, since it contains a fix that might get rid of this issue on your end).
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby Andrew » Thu May 21, 2009 3:55 pm

Hi.

This is my linux.
[dd]
sam@sw122:~$ uname -a
Linux sw122 2.6.29.4 #1 Wed May 20 17:59:24 EDT 2009 i686 Intel(R) Pentium(R) 4 CPU 1.60GHz GenuineIntel GNU/Linux
[dd]

I tried your latest client version (file renamed by me):
2050813 2009-05-20 09:16 vpnclient-linux-x86_64-4.8.02.0030-k9-2.tar.gz
but my linux behavior like this:
----------
Connect using Cisco VPN client - log in works fine.
Transfer ANY traffic over the vpn (even just a ping) causes crash (kernel panic).
----------
Is this patch for AMD only? I have P4. Could you clarify?

Thanks.
Andrew.
Andrew
Private
Private
 
Posts: 1
Joined: Thu May 21, 2009 3:43 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby mariuszs » Thu May 21, 2009 10:16 pm

tuxx-home.at wrote:Have you guys tried to switch off one CPU as mentioned in the sticky?

viewtopic.php?f=15&t=457

Please grab the latest client version from http://projects.tuxx-home.at/ciscovpn/c ... ux/4.8.02/ and try again (I have updated the package but not changed the version number, so even if you already downloaded this package, please download it again, since it contains a fix that might get rid of this issue on your end).


THANKS VERY MUCH, latest version fix my problem (kernel panic) on kernel 2.6.29.3-140.fc11.x86_64. I dont need to disable second CPU, im disabled selinux, but I dont know if this is really required (setenforce 0).
mariuszs
Sergeant
Sergeant
 
Posts: 18
Joined: Wed May 20, 2009 6:59 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby tuxx-home.at » Fri May 22, 2009 11:30 am

No, this has nothing todo with AMD or P4, it's a bug in interceptor.c. There are two packages available, the one from t3x which is ONLY for AMD64 cpus on 64bit operating systems and the other one which is to be used for all other platforms and CPU types.

I have applied the one-byte fix to all releases, but since this doesn't help you, I'm running out of ideas right now.
Can you actually see the kernel panic that causes your system to freeze? Maybe after reboot then, can you check if the panic has been logged to the logfiles (/var/log/kern.log or /var/log/syslog or something like that)?
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby whoami » Mon May 25, 2009 6:05 pm

Hi,

I tried using vpnclient-linux-x86_64-4.8.02.0030-k9.tar.gz on Kubuntu with below mentioned spec's:

Linux whoami 2.6.30-5-generic #6-Ubuntu SMP Mon May 11 19:56:30 UTC 2009 i686 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic

Hardware:
IBM T61
Centrino Duo Core

Installation went fine and i was able to connect using vpnclient, but the problem begins after the connection is established. For some reason system freezes the moment i try to pass any traffic. Secondly i've installed Cisco VPN Client version 4.8.02 and it shows version 4.8.01 as installed. i've tried uninstalling & installing but issue remains. I've used the patched images from your site. would really appreciate any help on this.

Cheers...!!!
whoami
Private
Private
 
Posts: 1
Joined: Mon May 25, 2009 5:59 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby xtom » Sun Jun 07, 2009 12:03 am

Hi

I have exactly same problem as 'whoami' when I run same version on 2.6.28 no problem at all but on 2.6.29 I can connect without any problem, but when I try use it its crash and do kernel panic.
If you will need some testing let me know.

Thanks for all your work
xtom
Private
Private
 
Posts: 4
Joined: Sun Jun 07, 2009 12:00 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby pepto » Sun Jun 14, 2009 12:55 pm

Could this be a src of problem :
http://bugzilla.kernel.org/show_bug.cgi?id=13097
causing kernel freezing with ciscovpn?

d.
pepto
Private
Private
 
Posts: 1
Joined: Sun Jun 14, 2009 12:52 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby mariuszs » Tue Jun 16, 2009 10:47 am

I have reinstalled vpn client after kernel update and now system is freezing after ping to remote host. :( The files on your page still have 1-bit patch? I have exactly this same error like at beginning.


Image
mariuszs
Sergeant
Sergeant
 
Posts: 18
Joined: Wed May 20, 2009 6:59 am

Next

Return to Cisco VPN Client on Linux systems

Who is online

Users browsing this forum: No registered users and 3 guests

cron