Kernel 2.6.29 + client 4.81.0640 causes crash

Installation, configuration and troubleshooting of the Cisco VPN Client on Linux systems

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby joseche » Tue Aug 04, 2009 3:05 am

I have the same problem, with:
kernel: 2.6.28-14 SMP
vpnclient: 0640 (it should be 4.8.02 according to the update in this thread !

My 2-cents here are: my computer didn't freeze today, all day, when using the ethernet !, so I guess this is about wireless cards.
joseche
Private
Private
 
Posts: 1
Joined: Tue Aug 04, 2009 2:54 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby mariuszs » Thu Sep 17, 2009 7:50 am

boscharun wrote:Finally, I tried to go with vpnc, the open source cisco compatible vpn client. Looks like you can configure it even with ssl/certificate support. Worked for me :mrgreen:
See the instructions here if you are interested in VPNC
http://www.toolsbysk.com/skforums/forum/Blah.pl?m-1247385296

VPNC dosent support client certificate authentication
man vpnc wrote: --auth-mode <psk/cert/hybrid>
Authentication mode:
· psk: pre-shared key (default)
· cert: server + client certificate (not implemented yet)
· hybrid: server certificate + xauth (if built with openssl
support)

The --auth-mode=cert is needed for this, but is not implemented yet.
mariuszs
Sergeant
Sergeant
 
Posts: 18
Joined: Wed May 20, 2009 6:59 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby alini76 » Sun Oct 04, 2009 10:07 pm

Hello,

I got a Lenovo T400, I installed Fedora 11 and trying to connect the VPN.
[root@alin-ro ~]# uname -a
Linux alin-ro.ro.oracle.com 2.6.30.8-64.fc11.x86_64 #1 SMP Fri Sep 25 04:43:32 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[root@alin-ro vpnclient]# grep "VERSION" config.h
#define VERSION "4.8.02"
[root@alin-ro vpnclient]# cat /proc/cpuinfo | grep "model name"
model name : Intel(R) Core(TM)2 Duo CPU T9400 @ 2.53GHz
model name : Intel(R) Core(TM)2 Duo CPU T9400 @ 2.53GHz

I have tested the issue disabling one of the cores and it is reproducible.
After the vpnclient connect command the computer freezes.

Thank you,
Alin Ilie
alini76
Private
Private
 
Posts: 1
Joined: Sun Oct 04, 2009 10:00 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby coopstah13 » Wed Oct 07, 2009 12:33 am

I am seeing the same thing as everyone else. I would also like to add that vpnc doesn't work with RSA SecurID (which is why i need to use cisco vpn).

Code: Select all
Linux ccooper-laptop 2.6.30-ARCH #1 SMP PREEMPT Wed Sep 9 12:37:32 UTC 2009 i686 Intel(R) Pentium(R) M processor 2.00GHz GenuineIntel GNU/Linux
coopstah13
Private
Private
 
Posts: 3
Joined: Thu Sep 17, 2009 12:22 am

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby skinnejay » Fri Oct 09, 2009 6:10 pm

Hi everyone, just wanted to add myself to the "me too" group. freezes with 4.81.0640 on kernel 2.6.31-12 (Ubuntu karmic). Hope there is a fix sometime soon! Thanks for all your hard work by the way.
skinnejay
Private
Private
 
Posts: 1
Joined: Fri Oct 09, 2009 6:06 pm

Re: Kernel 2.6.29 + client 4.81.0640 causes crash

Postby xtom » Fri Oct 16, 2009 11:01 pm

Hi here,

I posted here cumulative patch viewtopic.php?f=15&t=885#p5425 If you are interested try it should work.
xtom
Private
Private
 
Posts: 4
Joined: Sun Jun 07, 2009 12:00 am

Previous

Return to Cisco VPN Client on Linux systems

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron