Still problem installing cisco VPN

Installation, configuration and troubleshooting of the Cisco VPN Client on Linux systems

Still problem installing cisco VPN

Postby mrej » Fri Feb 20, 2009 2:23 am

I've tried to follow every single advice in those threads, but I can not find a solution.

I try to install what I believe is the latest version of Cisco's VPN, vpnclient-linux-x86_64-4.8.02.0030-k9.tar.gz
As far as I know, I have all kernel files and headers for my current kernel, 2.6.24-23-generic

This is my command window:
Code: Select all
mrej@mrej-laptop:~/VPN$ sudo vpnclient/vpn_install
Cisco Systems VPN Client Version 4.8.02 (0030) Linux Installer
Copyright (C) 1998-2006 Cisco Systems, Inc. All Rights Reserved.

By installing this product you agree that you have read the
license.txt file (The VPN Client license) and will comply with
its terms.


Directory where binaries will be installed [/usr/local/bin]

Automatically start the VPN service at boot time [yes]

In order to build the VPN kernel module, you must have the
kernel headers for the version of the kernel you are running.


Directory containing linux kernel source code [/lib/modules/2.6.24-23-generic/build]

* Binaries will be installed in "/usr/local/bin".
* Modules will be installed in "/lib/modules/2.6.24-23-generic/CiscoVPN".
* The VPN service will be started AUTOMATICALLY at boot time.
* Kernel source from "/lib/modules/2.6.24-23-generic/build" will be used to build the module.

Is the above correct [y]

Making module
sh: Can't open ./driver_build.sh
Failed to make module "cisco_ipsec.ko".
mrej@mrej-laptop:~/VPN$


As far as I can understand, something is still wrong with the header files. I tried to reinstall them all, but no change.

Do you have any ideas how to fix this?

sincerely
Erik
mrej
Private
Private
 
Posts: 1
Joined: Fri Feb 20, 2009 2:14 am

Re: Still problem installing cisco VPN

Postby tuxx-home.at » Fri Feb 20, 2009 7:44 pm

There's nothing wrong with the header fiels, you just may not execute the vpn_install script when the directory it resides in is not your CWD (current working directory). The installer itself is pretty poorly written, so to get rid of that, simply do:

Code: Select all
cd ~/VPN/vpnclient
sudo ./vpn_install


and it should work.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe


Return to Cisco VPN Client on Linux systems

Who is online

Users browsing this forum: No registered users and 1 guest

cron