Upgraded from 2.6.27-9 to 2.6.27-11

Installation, configuration and troubleshooting of the Cisco VPN Client on Linux systems

Upgraded from 2.6.27-9 to 2.6.27-11

Postby AJ » Thu Jan 29, 2009 11:51 pm

I didn't pay close enough to attention to the updates Ubuntu wanted to install and allowed a kernel upgrade, which of course broke my VPN.

This is 32bit, btw.

So tried to just re-install and that didn't work or rather when I attempt to run the "vpnclient_init start" I get this error:
Code: Select all
Starting /opt/cisco-vpnclient/bin/vpnclient: insmod: error inserting '/lib/modules/2.6.27-11-generic/CiscoVPN/cisco_ipsec.ko': -1 Invalid module format
Failed (insmod)


So I tried to uninstall first, then reboot and tried the install again with the same result. Here is what I see when installing

Code: Select all
Directory containing linux kernel source code [/lib/modules/2.6.27-11-generic/build]

* Binaries will be installed in "/usr/local/bin".
* Modules will be installed in "/lib/modules/2.6.27-11-generic/CiscoVPN".
* The VPN service will be started AUTOMATICALLY at boot time.
* Kernel source from "/lib/modules/2.6.27-11-generic/build" will be used to build the module.

Is the above correct [y]

Making module
make -C /lib/modules/2.6.27-11-generic/build SUBDIRS=/home/alan/Downloads/vpnclient modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-11-generic'
  CC [M]  /home/alan/Downloads/vpnclient/linuxcniapi.o
In file included from /home/alan/Downloads/vpnclient/Cniapi.h:15,
                 from /home/alan/Downloads/vpnclient/linuxcniapi.c:31:
/home/alan/Downloads/vpnclient/GenDefs.h:221:2: error: #endif without #if
make[2]: *** [/home/alan/Downloads/vpnclient/linuxcniapi.o] Error 1
make[1]: *** [_module_/home/alan/Downloads/vpnclient] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-11-generic'
make: *** [default] Error 2
Copying module to directory "/lib/modules/2.6.27-11-generic/CiscoVPN".
Already have group 'bin'

Creating start/stop script "/etc/init.d/vpnclient_init".
    /etc/init.d/vpnclient_init
Enabling start/stop script for run level 3,4 and 5.

Installing license.txt (VPN Client license) in "/opt/cisco-vpnclient/":
    /opt/cisco-vpnclient/license.txt

Installing bundled user profiles in "/etc/opt/cisco-vpnclient/Profiles/":
* Replaced Profiles: sample

Copying binaries to directory "/opt/cisco-vpnclient/bin".
Adding symlinks to "/usr/local/bin".
    /opt/cisco-vpnclient/bin/vpnclient
    /opt/cisco-vpnclient/bin/cisco_cert_mgr
    /opt/cisco-vpnclient/bin/ipseclog
Copying setuid binaries to directory "/opt/cisco-vpnclient/bin".
    /opt/cisco-vpnclient/bin/cvpnd
Copying libraries to directory "/opt/cisco-vpnclient/lib".
    /opt/cisco-vpnclient/lib/libvpnapi.so
Copying header files to directory "/opt/cisco-vpnclient/include".
    /opt/cisco-vpnclient/include/vpnapi.h

Setting permissions.
    /opt/cisco-vpnclient/bin/cvpnd (setuid root)
    /opt/cisco-vpnclient (group bin readable)
    /etc/opt/cisco-vpnclient (permissions not changed)
* You may wish to change these permissions to restrict access to root.
* You must run "/etc/init.d/vpnclient_init start" before using the client.
* This script will be run AUTOMATICALLY every time you reboot your computer.


I didn't try to patch as I was told before that the patch is not required for 2.6.27

Any recommendations would be appreciated.

Thanks

AJ
AJ
Major
Major
 
Posts: 23
Joined: Mon Nov 17, 2008 1:22 am

Re: Upgraded from 2.6.27-9 to 2.6.27-11

Postby tuxx-home.at » Mon Feb 02, 2009 3:57 pm

What VPN client version are you using? 4.8.02 should work without problems, but the error message you're getting is a bit strange:

Code: Select all
/home/alan/Downloads/vpnclient/GenDefs.h:221:2: error: #endif without #if


Could it be, that there's an error in the source files for the VPN client?

Anyhow, I'd suggest to remove the vpnclient directory in /home/alan/Downloads and start over with the latest vpn client (no patches needed).
You can download 4.8.02 from here:

[http://projects.tuxx-home.at/ciscovpn/clients/linux/]
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: Upgraded from 2.6.27-9 to 2.6.27-11

Postby AJ » Wed Feb 04, 2009 11:24 pm

tuxx-home.at wrote:What VPN client version are you using? 4.8.02 should work without problems, but the error message you're getting is a bit strange:

Code: Select all
/home/alan/Downloads/vpnclient/GenDefs.h:221:2: error: #endif without #if


Could it be, that there's an error in the source files for the VPN client?

Anyhow, I'd suggest to remove the vpnclient directory in /home/alan/Downloads and start over with the latest vpn client (no patches needed).
You can download 4.8.02 from here:

[http://projects.tuxx-home.at/ciscovpn/clients/linux/]


Using 4.8.02.

Should I run the uninstall command first? (After backing up my profile file, of course)

Thanks.
AJ
Major
Major
 
Posts: 23
Joined: Mon Nov 17, 2008 1:22 am

Re: Upgraded from 2.6.27-9 to 2.6.27-11

Postby tuxx-home.at » Thu Feb 05, 2009 2:15 pm

Uninstalling is not necessary but you can, of course, do that just to be sure.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: Upgraded from 2.6.27-9 to 2.6.27-11

Postby AJ » Sat Feb 28, 2009 10:31 pm

Finally got around to trying this and it worked like a charm.

Please close this thread.

Thanks.

AJ
AJ
Major
Major
 
Posts: 23
Joined: Mon Nov 17, 2008 1:22 am

Re: Upgraded from 2.6.27-9 to 2.6.27-11

Postby tuxx-home.at » Sat Feb 28, 2009 10:33 pm

Great, thanks for reporting back.

Closing now.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe


Return to Cisco VPN Client on Linux systems

Who is online

Users browsing this forum: No registered users and 3 guests

cron