Page 1 of 1

Cisco VPN Client on openSUSE with kernel 2.6.34.7

PostPosted: Wed Oct 06, 2010 3:54 pm
by Alvin11
Hi everybody.

I have problem with installation of Cisco VPN client on openSUSE with their latest kernel - 2.6.34.7. When I try to install it i get the following error:


Code: Select all
Cisco Systems VPN Client Version 4.8.02 (0030) Linux Installer
Copyright (C) 1998-2006 Cisco Systems, Inc. All Rights Reserved.

By installing this product you agree that you have read the
license.txt file (The VPN Client license) and will comply with
its terms.


Directory where binaries will be installed [/usr/local/bin]

Automatically start the VPN service at boot time [yes]

In order to build the VPN kernel module, you must have the
kernel headers for the version of the kernel you are running.


Directory containing linux kernel source code [/lib/modules/2.6.34.7-0.4-desktop/build]

* Binaries will be installed in "/usr/local/bin".
* Modules will be installed in "/lib/modules/2.6.34.7-0.4-desktop/CiscoVPN".
* The VPN service will be started AUTOMATICALLY at boot time.
* Kernel source from "/lib/modules/2.6.34.7-0.4-desktop/build" will be used to build the module.

Is the above correct [y]

Making module
make -C /lib/modules/2.6.34.7-0.4-desktop/build SUBDIRS=/home/ivailo/Downloads/Install/Cisco VPN Client For Linux/vpnclient modules
make[1]: Entering directory `/usr/src/linux-2.6.34.7-0.3'
make[1]: *** No rule to make target `VPN'.  Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.34.7-0.3'
make: *** [default] Error 2
Failed to make module "cisco_ipsec.ko".


The vpn client is patched usint the attached patch. I found the patch on http://bugs.gentoo.org/234361. Can anyone help me with the installation of this client?

Re: Cisco VPN Client on openSUSE with kernel 2.6.34.7

PostPosted: Tue Oct 12, 2010 7:53 pm
by Alvin11
OK, so I found the problem - never in any case put the Cisco VPN client in directory, which name contains spaces. I managed to install the client, however I have a new problem.

I need to connect to a remote Sun system and use X11 based app. However when I do this, the whole system freezes completely, not even the sysrq keys works. I have tested X11 forwarding with a system on the local network and it works OK. Also I tried both telnet and ssh -X to connect to the system with no luck at all. There are no error messages in any of the system logs. I also have tried using another distro - Kubuntu - on the same machine, with the same result. Can anybody help me on resolving this?