DVI with G550 and latest driver

This forum is for questions about all G-series cards (G200, G400, G450, ...) that need the mga driver to work properly

DVI with G550 and latest driver

Postby kleinklausi » Sun Feb 17, 2008 8:29 pm

Hi,

I can't get it working!

I want to connect a Matrox G550 via DVI to a Panasonic Projector (HDMI). The G550 is one with a VGA and a DVI connector. Attached are my xorg.conf and Xorg.0.log. I'm using the latest unofficial driver with Debian Etch Xorg.

Would be great if somebody can help!

Thanks in advance and regards,
Moritz

xorg.conf
(3.06 KiB) Downloaded 549 times

Xorg.0.log
(36.09 KiB) Downloaded 476 times
kleinklausi
Private
Private
 
Posts: 5
Joined: Sun Feb 17, 2008 8:21 pm

Re: DVI with G550 and latest driver

Postby tuxx-home.at » Sun Feb 17, 2008 9:47 pm

The problem might be that your resolution gets rejected due to bad timings:

(II) MGA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)


It seems as if your card is able to query the correct timing values via DDC (although I can't see these values in your logfile), but the correct values get overwritten by frequencies specified in your configuration file:

(WW) MGA(0): config file hsync range 30-70kHz not within DDC hsync ranges.
(WW) MGA(0): config file vrefresh range 50-87Hz not within DDC vrefresh ranges.


Try to comment out the 'VertRefresh' and 'HorizSync' lines in your configuration file, maybe that'll work:

Code: Select all
Section "Monitor"
   Identifier   "Beamer"
   Option      "DPMS"
#   HorizSync   30-70
#   VertRefresh   50-87
EndSection
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: DVI with G550 and latest driver

Postby kleinklausi » Sun Feb 17, 2008 10:02 pm

Hi,

It is working! Thank you very much. It is really awesome to have this forum. I was thinking that I need to specify the sync ranges.

What would be the best way to include the native resolution 1280x720. Do I need to create modelines?

Thanks and regards


tuxx-home.at wrote:The problem might be that your resolution gets rejected due to bad timings:
Try to comment out the 'VertRefresh' and 'HorizSync' lines in your configuration file, maybe that'll work:
kleinklausi
Private
Private
 
Posts: 5
Joined: Sun Feb 17, 2008 8:21 pm

Re: DVI with G550 and latest driver

Postby tuxx-home.at » Sun Feb 17, 2008 10:07 pm

Great :)

What would be the best way to include the native resolution 1280x720.


Simply try to activate this resolution in the Screen section. Usually, you won't need a specific modeline, so please try to activate the desired resolution and if it doesn't work, attach the latest Xorg.0.log file to your next message.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: DVI with G550 and latest driver

Postby kleinklausi » Sun Feb 17, 2008 10:30 pm

tuxx-home.at wrote:Great :)
Simply try to activate this resolution in the Screen section. Usually, you won't need a specific modeline, so please try to activate the desired resolution and if it doesn't work, attach the latest Xorg.0.log file to your next message.


I included the resolution and restarted the xserver:
Code: Select all
        SubSection "Display"
                Depth           16
                Modes           "1280x720" "1024x768" "800x600" "640x480"
        EndSubSection


But unfortunately the projector says it is a xga@60 signal. And the log states:
(II) MGA(0): Not using mode "1280x720" (no mode of this name)


Attached is the new log.
Xorg.0.log
(33.83 KiB) Downloaded 496 times


Thanks
kleinklausi
Private
Private
 
Posts: 5
Joined: Sun Feb 17, 2008 8:21 pm

Re: DVI with G550 and latest driver

Postby tuxx-home.at » Mon Feb 18, 2008 9:46 am

OK it seems as if the projector (a Panasonic AX-200, I assume) doesn't advertise this resolution and therefore it gets rejected without proper modeline settings.
Please try the following modeline:

Code: Select all
Modeline "1280x720@60" 74.30 1280 1312 1592 1624 720 735 742 757


Don't forget to tell your X server to use the "1280x720@60" resolution, e.g.:

Code: Select all
Section "Screen"
   [...]
   SubSection "Display"
      [...]
      Modes "1280x720@60"
   EndSubSection
EndSection
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: DVI with G550 and latest driver

Postby kleinklausi » Mon Feb 18, 2008 11:24 pm

tuxx-home.at wrote:
Code: Select all
Modeline "1280x720@60" 74.30 1280 1312 1592 1624 720 735 742 757

Code: Select all
Section "Screen"
   [...]
   SubSection "Display"
      [...]
      Modes "1280x720@60"
   EndSubSection
EndSection


Hi,

ich habe beides in meine xorg.conf eingefügt, aber jetzt bekomme ich unter anderem folgendes:
Code: Select all
(II) MGA(0): Not using mode "1280x720_60" (no mode of this name)

Ich muss wohl einen ziemlich einfachen Fehler gemacht haben, aber ich sehe ihn nicht...

Anbei noch die aktuellen conf und log Dateien.
xorg.conf
(3.21 KiB) Downloaded 471 times

Xorg.0.log
(33.63 KiB) Downloaded 449 times
kleinklausi
Private
Private
 
Posts: 5
Joined: Sun Feb 17, 2008 8:21 pm

Re: DVI with G550 and latest driver

Postby tuxx-home.at » Mon Feb 18, 2008 11:36 pm

Please don't change the language during our conversation. If you need to discuss a problem in German create a new topic in the designated subforum.

The given modeline seems to be out of sync on your beamer, so please tell me what brand/model is this beamer? Is it a Panasonic AX-200? What's the exact model name?

I found another modeline via Google, maybe this one works better:

Code: Select all
ModeLine "1280x720" 61.800 1280 1390 1430 1648 720 725 730 750 +hsync +vsync


Don't forget to change the corresponding lines in your Screen sections.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: DVI with G550 and latest driver

Postby kleinklausi » Mon Feb 18, 2008 11:52 pm

tuxx-home.at wrote:
Code: Select all
ModeLine "1280x720" 61.800 1280 1390 1430 1648 720 725 730 750 +hsync +vsync

Don't forget to change the corresponding lines in your Screen sections.


Sorry, I was writing in another forum in German.

The new modeline is not working as well - the same info/warning in the log. Yes it is a Panasonic PT AX200e. Is there a algorithm or tool to create modelines or is it more like try and error?

Regards
kleinklausi
Private
Private
 
Posts: 5
Joined: Sun Feb 17, 2008 8:21 pm

Re: DVI with G550 and latest driver

Postby tuxx-home.at » Wed Feb 20, 2008 9:30 am

Of course there are algorithms and tools too.
On Debian, f.ex., a package called "videogen" is available and there's also `xvidtune` which should be installed by default on your system.
There are several online modeline calculators available too.

The modelines I asked you to try where found with a Google search for "AX200 modeline 1280x720" but there are far more valid modelines out there so maybe
Google can help you to get a correct modeline for your projector.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Re: DVI with G550 and latest driver

Postby ubick21 » Sat Sep 20, 2008 2:01 pm

Hello,
I encountered the same problem. Thanks to your solution, it has solved partially my problem.
I still got one : I have to scroll up/down with the mouse on the projector screen to be able to access to the top/down of the screen.

Here is my configuration :
- ubuntu 64 bits hardy (last updates)
- video card : 8800 GTS 320Meg, DVI-I, hdcp (2 dvi outs)
- LCD viewsonic 22'
- panasonic PT-AX200E

I did what you proposed in xorg.conf file (you can find it in attachment)
- disabling HorizSync and VertRefresh
- add modeline for monitor section
- add SubSection mode for screen section

When I display the resolution of projector screen : "System->Preferences->screen resolution", I have 1280x768 (I do not understand why)

If you know how display the full screen through the projector (without having to scroll the mouse) I will appreciate!
thank you very much in advance for your answers.
Attachments
Xorg.0.log
(33.41 KiB) Downloaded 441 times
xorg.conf
(3.81 KiB) Downloaded 470 times
ubick21
Private
Private
 
Posts: 2
Joined: Sat Sep 20, 2008 1:48 pm

Re: DVI with G550 and latest driver

Postby ubick21 » Sat Sep 20, 2008 2:12 pm

youpiii I found the solution

Code: Select all
Section "Screen"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: 1280x720_60 +0+0"
EndSection
Attachments
xorg.conf
(3.13 KiB) Downloaded 638 times
ubick21
Private
Private
 
Posts: 2
Joined: Sat Sep 20, 2008 1:48 pm

Re: DVI with G550 and latest driver

Postby tuxx-home.at » Mon Oct 13, 2008 2:30 pm

Thanks for this information, ubick21.

kleinklausi, does this solution work for you too?
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe


Return to Matrox G-Series Cards

Who is online

Users browsing this forum: No registered users and 2 guests

cron