G450 on Ubuntu 7.10 Gusty Gibbon

This forum is for questions about all G-series cards (G200, G400, G450, ...) that need the mga driver to work properly

G450 on Ubuntu 7.10 Gusty Gibbon

Postby kag » Mon Oct 22, 2007 11:05 pm

I ran the matroxdriver_mga-x86_32-4.4.3-installer.run file and I get the following message:
Can't find the X Server version you are currently running (1.3.0) in
this installers database, so for your convenience, I'll try to install
the latest available version (7.1.0) onto your system.


I continue with the installation and I don't get any error message and everything seems to have worked correctly. However when I run glxgears it is obvious that 3D is not working properly. Also when I minimize and show back a window, the content is displayed almost instantly but the border and title bar are lagging a bit. When I move this Firefox window a little bit outside the desktop viewport and back in, the content is not painted instantly. I guess these are all signs of the driver not being installed?

I am attaching my xorg.conf and Xorg.0.log files in hope that you will be able to help me, I really want to dump Windows on my computer at work!

EDIT: after posting this, I copied the *.so files manually to /usr/lib/xorg/modules/drivers and restarted X. Now when I run glxgears, it runs smooth for the first second and then it crawls down. Weird!
Attachments
xorg.conf
(7.73 KiB) Downloaded 374 times
Xorg.0.log
(44.58 KiB) Downloaded 311 times
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby tuxx-home.at » Tue Oct 23, 2007 6:49 am

(**) MGA(0): Virtual size is 2048x1536 (pitch 2048)
[...]
(EE) MGA(0): Static buffer allocation failed, not initializing the DRI
(EE) MGA(0): Need at least 36864 kB video memory at this resolution, bit depth


I'm wondering about what resolution you're trying to achieve. In the first
device section you've set the resolution to 1280x960@24bpp and the virtual
screen size to 2048x1536.
The second screen is configured for 1024x768@24bpp with no virtual size
and that won't work.

The configured virtual size seems to be for four monitors each having
1024x768 in a 2x2 display wall, bus as you've only one G450 in your
system, you can't drive 4 monitors, so maybe you should reconfigure
your screen sections according to your needs?

E.g. if you're trying to have a simple dualhead layout, remove the "Virtual"
option from the first screen section and make sure that both screens have
the same resolution because in a merged setup, both screens should have
the same resolution.

If you need to run different resolutions on both monitors, you'll have to
use Xinerama and with that being enabled, you loose the ability for hard-
ware 3D acceleration on both screens as this is currently not possible with
the mga driver in Xinerama setups.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby kag » Tue Oct 23, 2007 2:38 pm

Actually I simply let the Gusty Gibbon "Screens and Graphics" utility manage the xorg.conf for me.

After your recommendations, I modified it by hand. Does it seem correct now? glxgears is still running very slow (~157fps).
Attachments
xorg.conf
(6.58 KiB) Downloaded 381 times
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby tuxx-home.at » Tue Oct 23, 2007 2:52 pm

Yes, xorg.conf looks better. Could I see the resulting Xorg.0.log file, please?
BTW: You enabled Xinerama now and that means that hardware acceleration
has been turned off, that's why the gears are rotating so slow.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby kag » Tue Oct 23, 2007 6:15 pm

When I disable Xinerama, the gears are fast in the main screen but slow in the secondary screen. I the Wikipedia article on Xinerama, and since I will definately want to move windows between screens, it means I would need to keep Xinerama enabled. I also have a 19" and a 17" monitor and I want them to have their own different resolution.

You said that enabling Xinerama disables 3D acceleration. Is this only for the current mga driver? For example if I switch my video card for a dual head nVidia, would I be able to enable Xinerama and still get 3D acceleration?

I included my Xorg.0.log file, before and after disabling Xinerama
Attachments
Xorg2.0.log
Xinerama disabled
(63.37 KiB) Downloaded 311 times
Xorg.0.log
Xinerama enabled
(43.8 KiB) Downloaded 305 times
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby tuxx-home.at » Tue Oct 23, 2007 9:03 pm

When I disable Xinerama, the gears are fast in the main screen but slow in
the secondary screen.


Exactly, that's the expected behaviour.
According to your needs, you do want to have Xinerama enabled, yes.

You said that enabling Xinerama disables 3D acceleration. Is this only for the
current mga driver?


Yes, because the Matrox drivers don't have their own Xinerama
implementation like the nVidia drivers f.ex. have (IIRC it's called TwinView
there).

For example if I switch my video card for a dual head nVidia, would I be
able to enable Xinerama and still get 3D acceleration?


Yes, that's correct.

If you'd like to stick with the Matrox card, you could try to configure
a so called MergedFB setup which allows for moving windows across your
screens _AND_ enables hardware acceleration on both screens, but
unfortunately, the MergedFB mode is currently a bit broken on the mga
driver so getting it to work is like playing the lottery.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby kag » Tue Oct 23, 2007 9:58 pm

Thank you very much, I think I get the whole picture. In the meantime I also read about MergedFB like you suggested. I'm going to try it in a few minutes, outside of my salaried hours. I think I have used enough of the company's time ;)
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby tuxx-home.at » Tue Oct 23, 2007 10:01 pm

OK, good luck.

BTW: How much of your precious time did your company demand? ;)
Think about that and playing with stuff like this during your work hours
becomes and absolutely reasonable thing.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby kag » Tue Oct 23, 2007 11:53 pm

To be honest, I haven't had to work unpaid hours here. I'm very well treated.

I followed this howto: http://ubuntuforums.org/showthread.php?p=1773710

When I add the mentioned block, I always get back to a very crappy resolution and both monitors are mirrored. I think an alternative xorg.conf is loaded (I think it's a new Gusty feature if you mess up your xorg.conf).

I'm attaching my xorg.conf file and the Xorg.0.log (although this one is from the alternative xorg.conf). I'm also attaching Xorg.0.log.old just in case... I'm not sure which is which.

Is my xorg.conf wrongly configured, or have I simply played the lottery and lost?
Attachments
Xorg.0.log.old
(38.83 KiB) Downloaded 294 times
Xorg.0.log
(38.75 KiB) Downloaded 303 times
xorg.conf
(5.01 KiB) Downloaded 312 times
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby kag » Fri Nov 09, 2007 9:59 pm

Bump for my last post :)
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby tuxx-home.at » Thu Nov 22, 2007 10:50 am

Sorry for the late answer, I somehow overlooked your posting :-/

Unfortunately, both logfiles are generated using the failsafe configuration,
so please try to start your X server manually:

Code: Select all
X -config /etc/X11/xorg.conf -ignoreABI -verbose >/root/X.out 2>&1


And attach the file "/root/X.out" to your next message.

Please make sure that you stop all instances of running X servers before
starting the X server with the above mentioned command. You might need
to stop your login manager (gdm, kdm, whatever) too in order to continue
with the above command.
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby kag » Thu Dec 06, 2007 10:44 pm

Thanks for getting back. I thought you didn't want to help anymore!

Here's my X.out file after manually starting X (it crashes). I'm also including xorg.conf.

I had to comment out lines 104-119 in order to start X properly (that's where I am right now). The resolution is fine, but the window borders and title bars are drawn very slowly. Also, last time I tried to run glxgear, Ubuntu completely froze and I had to "hard reboot".

Thanks again!!!
Attachments
X.out
(31.73 KiB) Downloaded 303 times
xorg.conf
(5.26 KiB) Downloaded 308 times
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby tuxx-home.at » Thu Dec 13, 2007 10:32 am

Option "Monitor2Hsync" "30-65" #Horizontal Sync of the Monitor (check your monitor's manual for correct values)
Option "Monitor2VRefresh" "50-75"


Are these values correct for your second monitor?
It seems as if you have two monitors of the same model and for the first
screen, the timing values are 30.0 - 96.0H and 48.0-120.0V.
Try to adjust the above mentioned monitor timings for the second screen
accordingly:

Code: Select all
[...]
        Option "Monitor2Hsync" "30-96"
        Option "Monitor2VRefresh" "48-120"
[...]
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Postby kag » Fri Dec 14, 2007 12:37 am

No, I have two different monitors. The first one is a Sony G420 and I believe its values are correct. The second monitor is a smaller Samsung SyncMaster 793DF. I believe I had the wrong values, I corrected them.

I cleaned up my xorg.conf so it's less confusing, but X still doesn't like my xorg.conf. And I simplified everything for now: I set both monitors to run in 1024x768. If I can get this working I'll be happy enough for now.

From what I understand from the logs, it's like my horizontal/vertical values aren't valid... but I believe they are!

Here are the new files... Thank you once again.
Attachments
X.out
(28.51 KiB) Downloaded 291 times
xorg.conf
(2.57 KiB) Downloaded 304 times
kag
Sergeant
Sergeant
 
Posts: 17
Joined: Mon Oct 22, 2007 10:59 pm

Postby tuxx-home.at » Mon Dec 31, 2007 10:21 am

That's exactly the problem with the current MergedFB implementation of the
mga driver. It somehow seems to refuse all timing values on the second head :-/

BTW: According to your X.out file, the first monitor supports these frequencies:

(II) MGA(0): Ranges: V min: 48 V max: 170 Hz, H min: 30 H max: 110 kHz, PixClock max 370 MHz
(II) MGA(0): Monitor name: CPD-G420S


The values for the Samsung seem to be correct...

If changing the timing values of the first monitor doesn't help, the only thing
you could try would be to swap the monitors on the outputs and change
your xorg.conf accordingly (e.g. swap the Vrefresh and Hsync options
from the Monitor section with the ones in the Screen section).
User avatar
tuxx-home.at
Supreme Commander
Supreme Commander
 
Posts: 2199
Joined: Mon Jan 01, 2007 12:51 pm
Location: Vassach - Austria - Europe

Next

Return to Matrox G-Series Cards

Who is online

Users browsing this forum: No registered users and 4 guests

cron